Erro no CentOS 6: [Errno 14] Peer cert cannot be verified or peer cert invalid

Se ainda usa o velho CentOS 6 pode se deparar com o erro abaixo ao tentar usar o yum para instalar algum pacote.

[Errno 14] Peer cert cannot be verified or peer cert invalid

Para solucionar, não do modo recomendado, mas que fará  o ym funcionar, siga a etapa abaixo:

  1. Abra o /etc/yum.conf com seu editor preferido. Aqui usarei o vi porque não tenho o vim instalado.  Você pode usar o nano se desejar.
    vi /etc/yum.conf
  2. Adicione a seguinte linha
    sslverify=false
  3. Salve o texto e saia.

 

Conclusão

Essa solução não é  a mais recomendada, mas também se você usa o CentOS 6 que saiu de linha há muito tempo não estará se importando muito com outras coisas(risos). Outra fator importante é que até o CentOS 8 não terá mais suporte. O Centos, em sua versão de atualização estável, não existirá mais. Procure outra distro ou pague pelo Red Hat.

Leitor voraz e um dos administradores do GNU/Linux Brasil no Whatsapp, facebook, youtube e nesse dito site: www.gnulinuxbrasil.com.br

One Comment to “Erro no CentOS 6: [Errno 14] Peer cert cannot be verified or peer cert invalid”

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *